Trang 1 của 2 12 CuốiCuối
Kết quả 1 đến 10 của 11

Chủ đề: Nhờ anh chị xem giúp e hàm vlookup với ạ

  1. #1
    nguoidoi893 Guest

  2. #2
    Ricky1990 Guest
    bạn sửa lại thế này

    Mã:
    =VLOOKUP(--LEFT(A1,2),Sheet1!$A$1:$C$42,2,0)

  3. #3
    Ngày tham gia
    Aug 2015
    Bài viết
    0
    Trích dẫn Gửi bởi rubyruby2015
    e làm file excel này nhưng cứ trả về kết quả NA. anh chị kiểm tra giùm e với ạ, e cảm ơn nhiều[IMG]images/smilies/a44.gif[/IMG]
    Mã:
    B1=VLOOKUP(--LEFT(A1,2),Sheet1!$A$1:$C$42,2,0)

  4. #4
    minhthai999 Guest
    e cảm ơn, nhưng tại sao cái thì ra kết quả còn một số cái vẫn hiện NA vậy ah

  5. #5
    daikaxomga Guest
    Trích dẫn Gửi bởi phulien1902
    <div class="bbcode_container">
    <div class="bbcode_description">HTML Code:
    </div>
    </div>
    e cảm ơn, nhưng tại sao cái thì ra kết quả còn một số cái vẫn hiện NA vậy ah

  6. #6
    tvhp2015 Guest
    Trích dẫn Gửi bởi rubyruby2015
    e cảm ơn, nhưng tại sao cái thì ra kết quả còn một số cái vẫn hiện NA vậy ah
    Có những ô phía trước nó không phải là số nên báo lỗi #Value, còn những ô báo lỗi #NA là do nó chỉ có một chữ số (do nó tự bỏ số 0 phía trước) trong khi những ô có giá trị từ 1 đến 9 thì bạn định dạng nó kiểu TEXT nên nó không tìm thấy, để khắc phục có 2 cách.
    Thứ nhất bạn định dạng lại từ A1 đến A8 trong sheet1 lại dạng số và ghi là 1-->9.
    Thứ hai là sửa công thức như sau:

    Mã:
    =IFERROR(VLOOKUP(--LEFT(A1,2),Sheet1!$A$1:$C$42,2,0),VLOOKUP(LEFT(A1,2),Sheet1!$A$1:$C$42,2,0))

  7. #7
    petduy Guest
    Trích dẫn Gửi bởi rubyruby2015
    e cảm ơn, nhưng tại sao cái thì ra kết quả còn một số cái vẫn hiện NA vậy ah
    Xin lỗi bạn vì đã không kiểm tra kỹ.
    Bạn có thể khắc phục với lỗi #N/A như sau:
    + Tại dòng 1: Data\ Filter\ AutoFilter, chọn #N/A
    + Bỏ "--" trước LEFT(...) đi và kéo công thức xuống.
    Hoặc dùng công thức của bạn giaiphap

  8. #8
    khanhklhn2 Guest
    Trích dẫn Gửi bởi phulien1902
    Xin lỗi bạn vì đã không kiểm tra kỹ.
    Bạn có thể khắc phục với lỗi #N/A như sau:
    + Tại dòng 1: Data\ Filter\ AutoFilter, chọn #N/A
    + Bỏ "--" trước LEFT(...) đi và kéo công thức xuống.
    Hoặc dùng công thức của bạn giaiphap
    e cảm ơn nhiều nha,[IMG]images/smilies/a44.gif[/IMG]

  9. #9
    sock123 Guest
    Trích dẫn Gửi bởi giaiphap
    Có những ô phía trước nó không phải là số nên báo lỗi #Value, còn những ô báo lỗi #NA là do nó chỉ có một chữ số (do nó tự bỏ số 0 phía trước) trong khi những ô có giá trị từ 1 đến 9 thì bạn định dạng nó kiểu TEXT nên nó không tìm thấy, để khắc phục có 2 cách.
    Thứ nhất bạn định dạng lại từ A1 đến A8 trong sheet1 lại dạng số và ghi là 1-->9.
    Thứ hai là sửa công thức như sau:

    <div class="bbcode_container">
    <div class="bbcode_description">Code:
    </div>
    </div>
    e cảm ơn nhiều ah[IMG]images/smilies/a44.gif[/IMG]

  10. #10
    Ngày tham gia
    Aug 2015
    Bài viết
    0
    Trích dẫn Gửi bởi phulien1902
    <div class="bbcode_container">
    <div class="bbcode_description">HTML Code:
    </div>
    </div>
    cho e hỏi chút, để trước -- trước hàm left có tác dụng gì vậy ạ

Trang 1 của 2 12 CuốiCuối

Quyền viết bài

  • Bạn Không thể gửi Chủ đề mới
  • Bạn Không thể Gửi trả lời
  • Bạn Không thể Gửi file đính kèm
  • Bạn Không thể Sửa bài viết của mình
  •